Google's Chrome version 45 has stopped support to java plugin (JAVA(TM)).Please use chrome version below 45. e-pass1000 & Watchkey e-token is not compatible
Notice / News